Pivotal + VMware: Transforming how more of the world builds software

All Vulnerability Reports

CVE-2019-3793: Invitations Service supports HTTP connections


Severity

High

Vendor

Pivotal

Description

Pivotal Apps Manager Release, versions 665.0.x prior to 665.0.28, versions 666.0.x prior to 666.0.21, versions 667.0.x prior to 667.0.7, contain an invitation service that accepts HTTP. A remote unauthenticated user could listen to network traffic and gain access to the authorization credentials used to make the invitation requests.

Affected Pivotal Products and Versions

Severity is high unless otherwise noted.

  • Pivotal Application Service
    • versions 665.0.x prior to 665.0.28
    • versions 666.0.x prior to 666.0.21
    • versions 667.0.x prior to 667.0.7
Mitigation

Users of affected versions should apply the following mitigation:

  • Releases that have fixed this issue include:
    • Pivotal Application Services 665.0.28, 666.0.21, 667.0.7
History

2019-04-12: Initial vulnerability report published.

Contact us