Pivotal + VMware: Transforming how more of the world builds software

All Vulnerability Reports

CVE-2019-11269: Open Redirector in spring-security-oauth2


Severity

Medium

Vendor

Spring by Pivotal

Description

Spring Security OAuth versions 2.3 prior to 2.3.6, 2.2 prior to 2.2.5, 2.1 prior to 2.1.5, and 2.0 prior to 2.0.18, as well as older unsupported versions could be susceptible to an open redirector attack that can leak an authorization code. A malicious user or attacker can craft a request to the authorization endpoint using the authorization code grant type, and specify a manipulated redirection URI via the redirect_uri parameter. This can cause the authorization server to redirect the resource owner user-agent to a URI under the control of the attacker with the leaked authorization code.

This vulnerability exposes applications that meet all of the following requirements:

  • Act in the role of an Authorization Server (e.g. @EnableAuthorizationServer)
  • Uses the DefaultRedirectResolver in the AuthorizationEndpoint

This vulnerability does not expose applications that:

  • Act in the role of an Authorization Server and use a different RedirectResolver implementation other than DefaultRedirectResolver
  • Act in the role of a Resource Server only (e.g. @EnableResourceServer)
  • Act in the role of a Client only (e.g. @EnableOAuthClient)

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Spring Security OAuth 2.3 to 2.3.5
  • Spring Security OAuth 2.2 to 2.2.4
  • Spring Security OAuth 2.1 to 2.1.4
  • Spring Security OAUth 2.0 to 2.0.17
Mitigation

Users of affected versions should apply the following mitigation:

  • 2.3.x users should upgrade to 2.3.6
  • 2.2.x users should upgrade to 2.2.5
  • 2.1.x users should upgrade to 2.1.5
  • 2.0.x users should upgrade to 2.0.18
  • Older versions should upgrade to a supported branch

There are no other mitigation steps necessary.

For users of Spring Boot 1.5.x and Spring IO Platform Cairo, it is highly recommended to override the spring-security-oauth version to the latest version containing the patch for the CVE. In order to override the version, you need to declare/set the property spring-security-oauth.version.

Below are instructions for users of Spring Boot 1.5.x.

To override a property using Maven, declare the property in your pom’s <properties> section:

<properties>
<spring-security-oauth.version>2.0.18.RELEASE</spring-security-oauth.version>
</properties>

To override a property using Gradle, configure the value in your build.gradle script:

ext['spring-security-oauth.version'] = '2.0.18.RELEASE'

Or in gradle.properties:

spring-security-oauth.version=2.0.18.RELEASE

NOTE: The same instructions apply for users of Spring IO Platform Cairo. However, the version to specify is 2.2.5.RELEASE.

Credit

This issue was identified and responsibly reported by Mike Noordermeer.

References
History

2019-05-30: Initial vulnerability report published

Contact us