CVE-2014-3625 Directory Traversal in Spring Framework


Severity

Moderate

Vendor

Spring by Pivotal

Versions Affected
  • Spring Framework 3.0.4 to 3.2.11
  • Spring Framework 4.0.0 to 4.0.7
  • Spring Framework 4.1.0 to 4.1.1
  • Other unsupported versions may also be affected
Description

Some URLs were not santized correctly before use allowing an attacker to obtain any file on the file system that was also accessible to process in which the Spring web application was running.

Mitigation

Users of affected versions should apply the following mitigation:

  • Users of 3.2.x should upgrade to 3.2.12 or later
  • Users of 4.0.x should upgrade to 4.0.8 or later
  • Users of 4.1.x should upgrade to 4.1.2 or later
Credit

This issue was identified by Toshiaki Maki of NTT DATA Corporation and responsibly reported to Pivotal.

References
History

2014-Nov-11: Initial vulnerability report published.