CVE-2013-7315 XML External Entity (XXE) injection in Spring Framework




Spring by Pivotal

Versions Affected
  • 3.2.0 to 3.2.3
  • 4.0.0.M1-4.0.0.M2 (Spring MVC)
  • Earlier unsupported versions may be affected

It was identified that Spring MVC processed user provided XML with JAXB in combination with a StAX XMLInputFactory without disabling external entity resolution. External entity resolution has been disabled in this case. It was subsequently discovered that this fix was incomplete (CVE-2013-6429, CVE-2014-0054).


Users of affected versions should apply the following mitigation:

  • Users of 3.x should upgrade to 3.2.4 or later
  • Users of 4.x should upgrade to 4.0.0.RC1 or later
  • To fully mitigate this issue (including CVE-2013-6429 & CVE-2014-0054), users of 3.x should upgrade to 3.2.8 or later and users of 4.x should upgrade to 4.0.2 or later.

These issues were identified by Alvaro Munoz of the HP Enterprise Security Team.


2013-Aug-22: Initial vulnerability report published under CVE-2013-4152.

2014-Jun-19: Created new vulnerability report for CVE-2013-7315 that was split off from the original vulnerability. Added information on additional vulnerability reports that identified that this fix was incomplete.