All Vulnerability Reports

CVE-2018-1275: Address partial fix for CVE-2018-1270


Severity

Critical

Vendor

Spring by Pivotal

Description

This CVE addresses the partial fix for CVE-2018-1270 in the 4.3.x branch of the Spring Framework.

Spring Framework, versions 5.0.x prior to 5.0.5 and versions 4.3.x prior to 4.3.16, as well as older unsupported versions allow applications to expose STOMP over WebSocket endpoints with a simple, in-memory STOMP broker through the spring-messaging module. A malicious user (or attacker) can craft a message to the broker that can lead to a remote code execution attack.

Affected Pivotal Products and Versions

Severity is critical unless otherwise noted.

  • Spring Framework 5.0 to 5.0.4
  • Spring Framework 4.3 to 4.3.15
  • Older unsupported versions are also affected
Mitigation

Users of affected versions should apply the following mitigation:

  • 5.0.x users should upgrade to 5.0.5
  • 4.3.x users should upgrade to 4.3.16
  • Older versions should upgrade to a supported branch

There are no other mitigation steps necessary.

Note that the use of authentication and authorization for messages, both of which are provided by Spring Security, limits exposure to this vulnerability to authorized users.

Credit

This original issue CVE-2018-1270 was identified and responsibly reported by Alvaro Muñoz (@pwntester), Micro Focus Fortify.

The subsequent CVE-2018-1275 partial fix was identified and responsibly reported independently by rwx, Christoph Dreis, and 0c0c0f from 360观星实验室.

References
History

2018-04-09: Initial vulnerability report published

2018-04-10: Updated credit section to list reporters for CVE-2018-1275

2018-04-13: Updated credit section with 0c0c0f from 360观星实验室