Pivotal + VMware: Transforming how more of the world builds software

All Vulnerability Reports

USN-3834-1: Perl vulnerabilities


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
Description

Jayakrishna Menon discovered that Perl incorrectly handled Perl_my_setenv. An attacker could use this issue to cause Perl to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2018-18311)

Eiichi Tsukata discovered that Perl incorrectly handled certain regular expressions. An attacker could use this issue to cause Perl to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 18.10. (CVE-2018-18312)

Eiichi Tsukata discovered that Perl incorrectly handled certain regular expressions. An attacker could use this issue to cause Perl to crash, resulting in a denial of service. (CVE-2018-18313)

Jakub Wilk discovered that Perl incorrectly handled certain regular expressions. An attacker could use this issue to cause Perl to crash, resulting in a denial of service. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 18.10. (CVE-2018-18314)

CVEs contained in this USN include: CVE-2018-18311, CVE-2018-18312, CVE-2018-18313, CVE-2018-18314

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.
  • Pivotal Application Service includes vulnerable stemcells and container rootfs in the following releases:
    • 2.4.x versions prior to 2.4.1
    • 2.3.x versions prior to 2.3.5
    • 2.2.x versions prior to 2.2.12
  • PCF Isolation Segment includes vulnerable stemcells and container rootfs in the following releases:
    • 2.4.x versions prior to 2.4.1
    • 2.3.x versions prior to 2.3.5
    • 2.2.x versions prior to 2.2.11
  • Pivotal Operations Manager is vulnerable in the following releases:
    • 2.4.x versions prior to 2.4.1
    • 2.3.x versions prior to 2.3.6
    • 2.2.x versions prior to 2.2.12
    • 2.1.x versions prior to 2.1.19
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry security team recommends upgrading BOSH to the affected OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.4.1, 2.3.5, 2.2.12
    • PCF Isolation Segment: 2.4.1, 2.3.5, 2.2.11
    • Pivotal Operations Manager: 2.4.1, 2.3.6, 2.2.12, 2.1.19
References
Contattaci