All Vulnerability Reports

CVE-2019-11293: UAA logs all query parameters with debug logging level


Severity

High

Vendor

Pivotal

Description

Pivotal Application Service versions prior to 2.7.6, 2.6.12 and 2.5.17 contain a vulnerable version of UAA, which logs client_secret credentials when sent as a query parameter when set to logging level DEBUG. A remote authenticated malicious user could gain access to user credentials via the uaa.log file if authentication is provided via query parameters.

Affected Pivotal Products and Versions

Severity is high unless otherwise noted.

  • Pivotal Application Service (PAS)
    • 2.7 versions prior to 2.7.6
    • 2.6 versions prior to 2.6.12
    • 2.5 versions prior to 2.5.17
Mitigation

Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include:

  • Pivotal Application Service (PAS)
    • 2.7.6
    • 2.5.17
    • 2.6.12
References
History

2019-12-03: Initial vulnerability report published.

Contattaci