All Vulnerability Reports

USN-4038-3: bzip2 regression


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
Description

USN-4038-1 fixed a vulnerability in bzip2. The update introduced a regression causing bzip2 to incorrect raises CRC errors for some files.

We apologize for the inconvenience.

Original advisory details:

It was discovered that bzip2 incorrectly handled certain files. An attacker could possibly use this issue to execute arbitrary code.

CVEs contained in this USN include: CVE-2016-3189, CVE-2019-12900

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.
  • Pivotal Operations Manager is vulnerable in the following releases:
    • 2.6.x versions prior to 2.6.5
    • 2.5.x versions prior to 2.5.11
    • 2.4.x versions prior to 2.4.17
    • 2.3.x versions prior to 2.3.23
  • Platform Automation for PCF is vulnerable in the following releases:
    • All versions prior to 3.0.4
  • Pivotal Greenplum for Kubernetes is vulnerable in the following releases:
    • All versions prior to 1.6.0
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry security team recommends upgrading BOSH to the affected OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • Pivotal Operations Manager: 2.6.5, 2.5.11, 2.4.17, 2.3.23
    • Platform Automation for PCF: 3.0.4
    • Pivotal Greenplum for Kubernetes: 1.6.0
References
Contact us