All Vulnerability Reports

USN-4001-1: libseccomp vulnerability


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
Description

Jann Horn discovered that libseccomp did not correctly generate 64-bit syscall argument comparisons with arithmetic operators (LT, GT, LE, GE). An attacker could use this to bypass intended access restrictions for argument-filtered system calls.

CVEs contained in this USN include: CVE-2019-9893

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.
  • Pivotal Application Service includes vulnerable stemcells in the following releases:
    • 2.5.x versions prior to 2.5
    • 2.4.x versions prior to 2.4
    • 2.3.x versions prior to 2.3
  • PCF Isolation Segment includes vulnerable stemcells in the following releases:
    • 2.5.x versions prior to 2.5
    • 2.4.x versions prior to 2.4
    • 2.3.x versions prior to 2.3
  • Pivotal Operations Manager is vulnerable in the following releases:
    • 2.6.x versions prior to 2.6.1
    • 2.5.x versions prior to 2.5.7
    • 2.4.x versions prior to 2.4.14
    • 2.3.x versions prior to 2.3.20
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry security team recommends upgrading BOSH to the affected OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.5, 2.4, 2.3
    • PCF Isolation Segment: 2.5, 2.4, 2.3
    • Pivotal Operations Manager: 2.6.1, 2.5.7, 2.4.14, 2.3.20
References
Contact us