All Vulnerability Reports

USN-3791-1: Git vulnerability


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 18.04
Description

It was discovered that git did not properly validate git submodule urls or paths. A remote attacker could possibly use this to craft a git repository that causes arbitrary code execution when recursive operations are used.

CVEs contained in this USN include: CVE-2018-17456

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Pivotal Application Service includes vulnerable container rootfs in the following releases:
    • 2.3.x versions prior to 2.3.2
    • 2.2.x versions prior to 2.2.8
    • 2.1.x versions prior to 2.1.16
    • 2.0.x versions prior to 2.0.24
  • PCF Isolation Segment includes vulnerable container rootfs in the following releases:
    • 2.3.x versions prior to 2.3.2
    • 2.2.x versions prior to 2.2.7
    • 2.1.x versions prior to 2.1.14
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry security team recommends upgrading BOSH to the affected OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.3.2, 2.2.8, 2.1.16, 2.0.24
    • PCF Isolation Segment: 2.3.2, 2.2.7, 2.1.14
References