All Vulnerability Reports

USN-3767-1: GLib vulnerabilities


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
Description

It was discovered that GLib incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2018-16428)

It was discovered that GLib incorrectly handled certain files. An attacker could possibly use this issue to access sensitive information. (CVE-2018-16429)

CVEs contained in this USN include: CVE-2018-16428, CVE-2018-16429

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.
  • Pivotal Application Service includes vulnerable stemcells and container rootfs in the following releases:
    • 2.3.x versions prior to 2.3.1
    • 2.2.x versions prior to 2.2.7
    • 2.1.x versions prior to 2.1.15
    • 2.0.x versions prior to 2.0.23
  • PCF Isolation Segment includes vulnerable stemcells and container rootfs in the following releases:
    • 2.3.x versions prior to 2.3.1
    • 2.2.x versions prior to 2.2.6
    • 2.1.x versions prior to 2.1.13
    • 2.0.x versions prior to 2.0.19
  • Pivotal Operations Manager is vulnerable in the following releases:
    • 2.2.x versions prior to 2.2.7
    • 2.1.x versions prior to 2.1.16
    • 2.0.x versions prior to 2.0.24
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry security team recommends upgrading BOSH to the affected OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.3.1, 2.2.7, 2.1.15, 2.0.23
    • PCF Isolation Segment: 2.3.1, 2.2.6, 2.1.13, 2.0.19
    • Pivotal Operations Manager: 2.2.7, 2.1.16, 2.0.24
References