All Vulnerability Reports

USN-3741-2: Linux kernel (Xenial HWE) vulnerabilities


Severity

High

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 14.04
Description

USN-3741-1 fixed vulnerabilities in the Linux kernel for Ubuntu 16.04 LTS. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 16.04 LTS for Ubuntu 14.04 LTS.

It was discovered that memory present in the L1 data cache of an Intel CPU core may be exposed to a malicious process that is executing on the CPU core. This vulnerability is also known as L1 Terminal Fault (L1TF). A local attacker in a guest virtual machine could use this to expose sensitive information (memory from other guests or the host OS). (CVE-2018-3646)

It was discovered that memory present in the L1 data cache of an Intel CPU core may be exposed to a malicious process that is executing on the CPU core. This vulnerability is also known as L1 Terminal Fault (L1TF). A local attacker could use this to expose sensitive information (memory from the kernel or other processes). (CVE-2018-3620)

Juha-Matti Tilli discovered that the TCP implementation in the Linux kernel performed algorithmically expensive operations in some situations when handling incoming packets. A remote attacker could use this to cause a denial of service. (CVE-2018-5390)

Juha-Matti Tilli discovered that the IP implementation in the Linux kernel performed algorithmically expensive operations in some situations when handling incoming packet fragments. A remote attacker could use this to cause a denial of service. (CVE-2018-5391)

CVEs contained in this USN include: CVE-2018-3620, CVE-2018-3646, CVE-2018-5390, CVE-2018-5391

Affected Pivotal Products and Versions

Severity is high unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.
  • Pivotal Application Service includes vulnerable stemcells in the following releases:
    • 2.2.x versions prior to 2.2.5
    • 2.1.x versions prior to 2.1.13
    • 2.0.x versions prior to 2.0.21
  • PCF Isolation Segment includes vulnerable stemcells in the following releases:
    • 2.2.x versions prior to 2.2.5
    • 2.1.x versions prior to 2.1.11
    • 2.0.x versions prior to 2.0.17
  • Pivotal Operations Manager is vulnerable in the following releases:
    • 2.2.x versions prior to 2.2.3
    • 2.1.x versions prior to 2.1.12
    • 2.0.x versions prior to 2.0.21
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry security team recommends upgrading BOSH stemcells and/or other OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.2.5, 2.1.13, 2.0.21
    • PCF Isolation Segment: 2.2.5, 2.1.11, 2.0.17
    • Pivotal Operations Manager: 2.2.3, 2.1.12, 2.0.21
References