All Vulnerability Reports

USN-3736-1: libarchive vulnerabilities


Severity

Low

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
Description

It was discovered that libarchive incorrectly handled certain archive files. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2016-10209, CVE-2016-10349, CVE-2016-10350)

Agostino Sarubbo discovered that libarchive incorrectly handled certain XAR files. A remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2017-14166)

It was discovered that libarchive incorrectly handled certain files. A remote attacker could possibly use this issue to get access to sensitive information. (CVE-2017-14501, CVE-2017-14503)

CVEs contained in this USN include: CVE-2016-10209, CVE-2016-10349, CVE-2016-10350, CVE-2017-14166, CVE-2017-14501, CVE-2017-14503

Affected Pivotal Products and Versions

Severity is low unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.
  • Pivotal Application Service includes vulnerable stemcells and container rootfs in the following releases:
    • 2.2.x versions prior to 2.2.5
    • 2.1.x versions prior to 2.1.12
    • 2.0.x versions prior to 2.0.21
  • PCF Isolation Segment includes vulnerable stemcells and container rootfs in the following releases:
    • 2.2.x versions prior to 2.2.5
    • 2.1.x versions prior to 2.1.11
    • 2.0.x versions prior to 2.0.17
  • Pivotal Operations Manager is vulnerable in the following releases:
    • 2.2.x versions prior to 2.2.3
    • 2.1.x versions prior to 2.1.12
    • 2.0.x versions prior to 2.0.21
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry security team recommends upgrading BOSH stemcells and/or other OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.3.0, 2.2.5, 2.1.12, 2.0.21
    • PCF Isolation Segment: 2.3.0, 2.2.5, 2.1.11, 2.0.17
    • Pivotal Operations Manager: 2.2.3, 2.1.12, 2.0.21
References