All Vulnerability Reports

USN-3692-1: OpenSSL vulnerabilities


Severity

Low

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 14.04
Description

Keegan Ryan discovered that OpenSSL incorrectly handled ECDSA key generation. An attacker could possibly use this issue to perform a cache-timing attack and recover private ECDSA keys. (CVE-2018-0495)

Guido Vranken discovered that OpenSSL incorrectly handled very large prime values during a key agreement. A remote attacker could possibly use this issue to consume resources, leading to a denial of service. (CVE-2018-0732)

Alejandro Cabrera Aldaya, Billy Brumley, Cesar Pereida Garcia and Luis Manuel Alvarez Tapia discovered that OpenSSL incorrectly handled RSA key generation. An attacker could possibly use this issue to perform a cache-timing attack and recover private RSA keys. (CVE-2018-0737)

CVEs contained in this USN include: CVE-2018-0495, CVE-2018-0732, CVE-2018-0737

Affected Pivotal Products and Versions

Severity is low unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.
  • Pivotal Application Service includes vulnerable stemcells and container rootfs in the following releases:
    • 2.2.x versions prior to 2.2.3
    • 2.1.x versions prior to 2.1.10
    • 2.0.x versions prior to 2.0.19
  • PCF Isolation Segment includes vulnerable stemcells and container rootfs in the following releases:
    • 2.2.x versions prior to 2.2.3
    • 2.1.x versions prior to 2.1.9
    • 2.0.x versions prior to 2.0.15
  • Pivotal Operations Manager is vulnerable in the following releases:
    • 2.1.x versions prior to 2.1.7
    • 2.0.x versions prior to 2.0.16
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry security team recommends upgrading BOSH stemcells and/or other OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.2.3, 2.1.10, 2.0.19
    • PCF Isolation Segment: 2.2.3, 2.1.9, 2.0.15
    • Pivotal Operations Manager: 2.1.7, 2.0.16
References