All Vulnerability Reports

USN-3256-2 Linux kernel (HWE) vulnerability


Severity

High

References
Description

CVEs contained in this USN include: CVE-2017-7308

Affected Pivotal Products and Versions

Severity is high unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Pivotal products using CF components prior to the listed updated versions are vulnerable to this issue. See the Mitigation section below for more information.
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry team recommends upgrading BOSH stemcells and/or other OSS components listed here if applicable.
  • Upgrade Pivotal products using earlier versions of CF components to new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • PCF Elastic Runtime: 1.6.75, 1.7.60, 1.8.39, 1.9.17, 1.10.4
    • PCF Isolation Segment: 1.10.2

Special Note for 1.7.x and above Ops Manager Deployments

The 1.7.x, 1.8.x, 1.9.x, and 1.10.x release line of Ops Manager includes a new feature that allows tile stemcells to “float”, which lets Operators update their Ops Manager deployment once rather than installing all new Services product releases. If you upgrade one Service tile in Ops Manager with the newly released stemcell, all tiles will automatically upgrade. For more information about the floating stemcell feature, refer to this document.