USN-3061-1 OpenSSH vulnerability


Severity

Medium

Vendor

Canonical Ubuntu, openssh

Versions Affected
  • Canonical Ubuntu 14.04 LTS
Description

Eddie Harari discovered that OpenSSH incorrectly handled password hashing when authenticating non-existing users. A remote attacker could perform a timing attack and enumerate valid users. (CVE-2016-6210)

Tomas Kuthan, Andres Rojas, and Javier Nieto discovered that OpenSSH did not limit password lengths. A remote attacker could use this issue to cause OpenSSH to consume resources, leading to a denial of service. (CVE-2016-6515)

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Cloud Foundry BOSH stemcells 3146.x versions prior to 3146.20 AND 3232.x versions prior to 3232.17 AND other versions prior to 3262.8 are vulnerable
  • All versions of Cloud Foundry cflinuxfs2 prior to v.1.75.0
  • PCF Ops Manager versions prior to 1.6.19 and 1.7.x versions prior to 1.7.11
  • PCF Elastic Runtime versions prior to 1.6.37 and 1.7.x versions prior to 1.7.15
  • MySQL for PCF versions prior to 1.6.14 and 1.7.x versions prior to 1.7.12
  • RiakCS for PCF versions prior to 1.5.14
  • RabbitMQ for PCF versions prior to 1.5.14 and 1.6.x versions prior to 1.6.6
  • Redis for PCF versions prior to 1.4.29 and 1.5.x versions prior to 1.5.14
  • PCF Metrics versions prior to 1.0.11 and 1.1.x versions prior to 1.1.0
  • PCF JMX Bridge (Ops Metrics) versions prior to 1.4.23 and 1.6.x versions prior to 1.6.16 and 1.7.x versions prior to 1.7.2
  • PCF Log Search versions prior to 1.0.0
  • Spring Cloud Services for PCF versions prior to 1.0.12 and 1.1.x versions prior to 1.1.2
  • Single Sign On for PCF 1.0.x versions prior to 1.0.16 AND 1.1.x versions prior to 1.1.1
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry team has released patched BOSH stemcells 3146.20 and 3232.17 with an upgraded Linux kernel that resolves the aforementioned issues. We recommend that Operators upgrade BOSH stemcell 3146.x versions to 3146.20 OR 3232.x versions to 3232.17
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs2 v.1.75.0 or later versions3232
  • Upgrade PCF Ops Manager to 1.6.19 or 1.7.x versions to 1.7.11
  • Upgrade PCF Elastic Runtime to 1.6.37 or 1.7.x versions to 1.7.15
  • Upgrade MySQL for PCF to 1.6.14 or 1.7.x versions to 1.7.12
  • Upgrade RiakCS for PCF to 1.5.14
  • Upgrade RabbitMQ for PCF to version 1.5.14 or 1.6.x versions to 1.6.6
  • Upgrade Redis for PCF to version 1.4.29 or 1.5.x versions to 1.5.14
  • Upgrade PCF Metrics to 1.0.11 or 1.1.x versions to 1.1.0
  • PCF JMX Bridge (Ops Metrics) to 1.4.23 or 1.6.x versions to 1.6.16 or 1.7.x versions to 1.7.2
  • Upgrade PCF Log Search to version 1.0.0
  • Upgrade Spring Cloud Services for PCF to 1.0.12 or 1.1.x versions to 1.1.2
  • Upgrade Single Sign On for PCF 1.0.x versions prior to 1.0.16 AND 1.1.x versions prior to 1.1.1

Special Note for 1.7.x Ops Manager Deployments

The 1.7.x release line of Ops Manager includes a new feature that allows tile stemcells to “float”, which will allow Operators to update their Ops Manager deployment once rather than installing all new Services product releases. If you upgrade one Service tile in Ops Manager 1.7.x with the newly released stemcell, all tiles will automatically upgrade. For more information about the floating stemcell feature, refer to this document.

Credit

Eddie Harari, Tomas Kuthan, Javier Nieto, and Andres Rojas

References