USN-2966-1 OpenSSH vulnerabilities


Severity

Low

Vendor

Canonical Ubuntu, openssh

Versions Affected
  • Canonical Ubuntu 14.04 LTS
Description

Shayan Sadigh discovered that OpenSSH incorrectly handled environment files when the UseLogin feature is enabled. A local attacker could use this issue to gain privileges. (CVE-2015-8325)

Ben Hawkes discovered that OpenSSH incorrectly handled certain network traffic. A remote attacker could possibly use this issue to cause OpenSSH to crash, resulting in a denial of service. This issue only applied to Ubuntu 15.10. (CVE-2016-1907)

Thomas Hoger discovered that OpenSSH incorrectly handled untrusted X11 forwarding when the SECURITY extension is disabled. A connection configured as being untrusted could get switched to trusted in certain scenarios, contrary to expectations. (CVE-2016-1908)

It was discovered that OpenSSH incorrectly handled certain X11 forwarding data. A remote authenticated attacker could possibly use this issue to bypass certain intended command restrictions. (CVE-2016-3115)

Affected Pivotal Products and Versions

Severity is low unless otherwise noted.

  • All versions of Cloud Foundry cflinuxfs2 prior to v.1.56.0
  • Cloud Foundry BOSH stemcells 3146.x versions prior to 3146.12 AND other versions prior to 3232.4 are vulnerable
  • Pivotal Elastic Runtime 1.6.x versions prior to 1.6.27 AND 1.7.x versions prior to 1.7.5
  • Pivotal Cloud Foundry Ops Manager versions prior to 1.6.13 AND 1.7.x versions prior to 1.7.3
  • MySQL for Pivotal Cloud Foundry versions prior to 1.6.11, versions 1.7.x prior to 1.7.8 AND 1.8.x prior to 1.8.0-edge.6
  • RabbitMQ for Pivotal Cloud Foundry versions prior to 1.5.10
  • Redis for Pivotal Cloud Foundry versions prior to 1.4.24 AND 1.5.x versions prior to 1.5.13
  • RiakCS for Pivotal Cloud Foundry versions prior to 1.5.12
  • Pivotal Cloud Foundry Single Sign-on versions prior to 1.0.12
  • Pivotal Push Notification Service 1.4.x versions prior to 1.4.9
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs2 v.1.56.0 or later versions
  • The Cloud Foundry project recommends that Cloud Foundry upgrade BOSH stemcell 3146.x versions to 3146.12 OR other versions to 3232.4
  • Upgrade Pivotal Elastic Runtime 1.6.x versions to 1.6.27 OR 1.7.x versions to 1.7.5
  • The Cloud Foundry project recommends that Cloud Foundry upgrade BOSH stemcell 3146.x versions to 3146.12 OR other versions to 3232.4
  • Pivotal Cloud Foundry Ops Manager versions prior to 1.6.13 should be upgraded to that release or higher AND 1.7.x versions should be upgraded to 1.7.3 or higher
  • MySQL for Pivotal Cloud Foundry versions prior to 1.6.11 should be upgraded to that release or higher, versions 1.7.x should be upgraded to 1.7.8 or higher AND 1.8.x prior to 1.8.0-edge.6 should be upgraded to that or higher
  • RabbitMQ for Pivotal Cloud Foundry versions prior to 1.5.10 should be upgraded to that release or higher
  • Redis for Pivotal Cloud Foundry versions prior to 1.4.24 should be upgraded to that release or higher AND 1.5.x versions prior to 1.5.13 should be upgraded to that release or higher
  • RiakCS for Pivotal Cloud Foundry versions prior to 1.5.12 should be upgraded to that release or higher
  • Pivotal Cloud Foundry Single Sign-on versions prior to 1.0.12 should be upgraded to that release or higher
  • Upgrade Pivotal Push Notification Service 1.4.x versions to 1.4.9
Credit

Ben Hawkes, Thomas Hoger, Shayan Sadigh

References