USN-2868-1 DHCP vulnerability


Severity

Medium

Vendor

DHCP

Versions Affected
  • Ubuntu 14.04
Description

Sebastian Poehn discovered that the DHCP server, client, and relay incorrectly handled certain malformed UDP packets. A remote attacker could use this issue to cause the DHCP server, client, or relay to stop responding, resulting in a denial of service.

The Cloud Foundry project released a BOSH stemcell version 3146.3 that has the patched version of the Linux kernel. A new Cloud Foundry rootfs was also released, cflinuxfs2 v.1.28.0, that has the patches.

Pivotal is releasing an updated version of Pivotal Cloud Foundry Suite which references this patched BOSH stemcell and CF rootfs.

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • All versions of Cloud Foundry BOSH stemcells prior to 3146.3 are vulnerable.
  • All versions of Cloud Foundry cflinuxfs2 prior to v.1.28.0.
  • Pivotal Cloud Foundry Elastic Runtime pre-1.5.11 versions and 1.6.x versions prior to 1.6.11.
  • Pivotal Ops Manager pre-1.5.12 versions and 1.6.x versions prior to 1.6.7.
  • Pivotal MySQL pre-1.6.5 versions and 1.7.x versions prior to 1.7.2.
  • Pivotal Redis pre-1.4.16 versions and 1.5.x versions prior to 1.5.5.
  • Pivotal Gemfire SSC pre-1.1.0.5 versions and pre-1.1.7.0 versions.
  • Pivotal RabbitMQ pre-1.5.3 versions.
  • Pivotal Ops Metrics pre-1.4.10 versions and pre-1.6.4 versions.
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry project recommends that Cloud Foundry deployments run with BOSH stemcells 3146.3 or later versions and cflinuxfs2 v.1.28.0 or later versions.
  • Pivotal recommends that customers upgrade to the 1.5.9 or later 1.5.x versions or the 1.6.6 or later versions of Pivotal Cloud Foundry Elastic Runtime.
  • 1.5.12 or later 1.5.x versions or the 1.6.7 or later versions of Pivotal Ops Manager.
  • 1.6.5 or later 1.6.x versions or the 1.7.2 or later versions of Pivotal MySQL.
  • 1.1.0.5 or later 1.1.0.x versions or the 1.1.7.0 or later versions of Pivotal Gemfire SSC.
  • 1.4.16 or later 1.4.x versions and 1.5.5 or later versions of Pivotal Redis.
  • 1.5.3 or later versions of RabbitMQ.
  • The 1.4.10 or later 1.4.x versions or the 1.6.4 or later versions of Pivotal Ops Metrics.
Credit

Sebastian Poehn

References