USN-2842-1/USN-2842-2 Linux kernel vulnerability
- Ubuntu 14.04
Jan Beulich discovered that the KVM svm hypervisor implementation in the Linux kernel did not properly catch Debug exceptions on AMD processors. An attacker in a guest virtual machine could use this to cause a denial of service (system crash) in the host OS. (CVE-2015-8104)
郭永刚 discovered that the ppp implementation in the Linux kernel did not ensure that certain slot numbers are valid. A local attacker with the privilege to call ioctl() on /dev/ppp could cause a denial of service (system crash). (CVE-2015-7799)
It was discovered that the virtual video osd test driver in the Linux kernel did not properly initialize data structures. A local attacker could use this to obtain sensitive information from the kernel. (CVE-2015-7884)
It was discovered that the driver for Digi Neo and ClassicBoard devices did not properly initialize data structures. A local attacker could use this to obtain sensitive information from the kernel. (CVE-2015-7885)
The Cloud Foundry project released a BOSH stemcell version 3146.1 and 3160 that has the patched version of the Linux kernel.
Pivotal is releasing an updated version of Pivotal Cloud Foundry Suite which references this patched BOSH stemcell.
Severity is medium unless otherwise noted.
- All versions of Cloud Foundry BOSH stemcells prior to 3160 are vulnerable, besides patched versions of 3146.x.
- Pivotal Cloud Foundry Elastic Runtime pre-1.5.9 versions and 1.6.x versions prior to 1.6.9.
- Pivotal Ops Manager pre-1.5.11 versions and 1.6.x versions prior to 1.6.6.
- Pivotal Redis pre-1.4.15 versions and 1.5.x versions prior to 1.5.4.
- Pivotal Gemfire SSC pre-188.8.131.52 versions and 1.1.x versions before 184.108.40.206.
- Pivotal RabbitMQ pre-1.5.2 versions.
- Pivotal Ops Metrics pre-1.4.9 versions, all 1.5.x versions, and all 1.6.x versions prior to 1.6.2.
Users of affected versions should apply the following mitigation:
- The Cloud Foundry project recommends that Cloud Foundry deployments run with BOSH stemcells 3160 or later versions, or patched 3146.x versions.
- Pivotal recommends that customers upgrade to the 1.5.10 or later 1.5.x versions or the 1.6.9 or later versions of Pivotal Cloud Foundry Elastic Runtime.
- 1.5.11 or later 1.5.x versions or the 1.6.6 or later versions of Pivotal Ops Manager.
- 220.127.116.11 or later versions of Pivotal Gemfire SSC and 18.104.22.168 or later 1.1.0.x versions.
- 1.4.15 or later 1.4.x versions and 1.5.4 or later versions of Pivotal Redis.
- 1.5.2 or later versions of RabbitMQ.
- The 1.4.9 or later 1.4.x versions or the 1.6.2 or later versions of Pivotal Ops Metrics.
Jan Beulich, 郭永刚