USN-2830-1 OpenSSL vulnerability


Severity

Medium

Vendor

OpenSSL

Versions Affected
  • Ubuntu 14.04
Description

Loïc Jonas Etienne discovered that OpenSSL incorrectly handled ASN.1 signatures with a missing PSS parameter. A remote attacker could possibly use this issue to cause OpenSSL to crash, resulting in a denial of service. (CVE-2015-3194)

Adam Langley discovered that OpenSSL incorrectly handled malformed X509_ATTRIBUTE structures. A remote attacker could possibly use this issue to cause OpenSSL to consume resources, resulting in a denial of service. (CVE-2015-3195)

The Cloud Foundry project released a BOSH stemcell version 3146.1 and 3149 that has the patched version of the Linux kernel. A new Cloud Foundry rootfs was also released, cflinuxfs2 v.1.21.0, that has the patches.

Pivotal is releasing an updated version of Pivotal Cloud Foundry Suite which references this patched BOSH stemcell and CF rootfs.

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • All versions of Cloud Foundry BOSH stemcells prior to 3149 are vulnerable, besides patched versions of 3146.x.
  • All versions of Cloud Foundry cflinuxfs2 prior to v.1.21.0.
  • Pivotal Cloud Foundry Elastic Runtime pre-1.5.9 versions and 1.6.x versions prior to 1.6.9.
  • Pivotal Ops Manager pre-1.5.11 versions and 1.6.x versions prior to 1.6.6.
  • Pivotal Redis pre-1.4.15 versions and 1.5.x versions prior to 1.5.4.
  • Pivotal Gemfire SSC pre-1.1.0.4 versions and 1.1.x versions before 1.1.6.0.
  • Pivotal RabbitMQ pre-1.5.2 versions.
  • Pivotal Ops Metrics pre-1.4.9 versions, all 1.5.x versions, and all 1.6.x versions prior to 1.6.2.
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry project recommends that Cloud Foundry deployments run with BOSH stemcells 3149 or later versions, or patched 3146.x versions, and cflinuxfs2 v.1.21.0 or later versions.
  • Pivotal recommends that customers upgrade to the 1.5.10 or later 1.5.x versions or the 1.6.9 or later versions of Pivotal Cloud Foundry Elastic Runtime.
  • 1.5.11 or later 1.5.x versions or the 1.6.6 or later versions of Pivotal Ops Manager.
  • 1.1.6.0 or later versions of Pivotal Gemfire SSC and 1.1.0.4 or later 1.1.0.x versions.
  • 1.4.15 or later 1.4.x versions and 1.5.4 or later versions of Pivotal Redis.
  • 1.5.2 or later versions of RabbitMQ.
  • The 1.4.9 or later 1.4.x versions or the 1.6.2 or later versions of Pivotal Ops Metrics.
Credit

Loïc Jonas Etienne and Adam Langley

References