USN-2815-1 PNG vulnerability


Severity

Medium

Vendor

PNG

Versions Affected
  • Ubuntu 14.04
Description

Qixue Xiao discovered that libpng incorrectly handled certain time values. If a user or automated system using libpng were tricked into opening a specially crafted image, an attacker could exploit this to cause libpng to crash, leading to a denial of service.

It was discovered that libpng incorrectly handled certain small bit-depth values. If a user or automated system using libpng were tricked into opening a specially crafted image, an attacker could exploit this to cause a denial of service or execute code with the privileges of the user invoking the program.

The Cloud Foundry project released a BOSH stemcell version 3144 that has the patched version of the Linux kernel. A new Cloud Foundry rootfs was also released, cflinuxfs2 v.1.19.0, that has the patches.

Pivotal is releasing an updated version of Pivotal Cloud Foundry Suite which references this patched BOSH stemcell and CF rootfs.

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • All versions of Cloud Foundry BOSH stemcells prior to 3143 are vulnerable.
  • All versions of Cloud Foundry cflinuxfs2 prior to v.1.19.0.
  • Pivotal Cloud Foundry Elastic Runtime pre-1.6.5 versions.
  • Pivotal Ops Manager pre-1.5.10 versions and 1.6.x versions prior to 1.6.5.
  • Pivotal Redis pre-1.4.13 versions and 1.5.0.
  • Pivotal Gemfire SSC pre-1.1.4.0 versions.
  • Pivotal RabbitMQ pre-1.4.9 versions.
  • Pivotal Ops Metrics pre-1.4.7 versions and all 1.5.x versions.
  • Pivotal MySQL pre-1.6.3.3 versions and 1.7.0.x versions prior to 1.7.0.3.
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry project recommends that Cloud Foundry deployments run with BOSH stemcells 3137 or later versions and cflinuxfs2 v.1.18.0 or later versions.
  • Pivotal recommends that customers upgrade to the 1.6.5 or later versions of Pivotal Cloud Foundry Elastic Runtime.
  • 1.5.10 or later 1.5.x versions or the 1.6.3 or later versions of Pivotal Ops Manager.
  • The 1.1.4.0 or later versions of Pivotal Gemfire SSC.
  • 1.4.13 or later 1.4.x versions and 1.5.1 or later versions of Pivotal Redis.
  • 1.4.9 or later versions of RabbitMQ.
  • The 1.4.7 or later 1.4.x versions or the 1.6.0 or later versions of Pivotal Ops Metrics.
  • The 1.6.3.3 or later 1.6.x versions or the 1.7.0.3 or later versions of Pivotal MySQL.
Credit

Qixue Xiao

References