USN-2810-1 Kerberos vulnerability


Severity

Medium

Vendor

Kerberos

Versions Affected
  • Ubuntu 14.04
Description

It was discovered that Kerberos incorrectly handled null bytes in certain data fields. A remote attacker could possibly use this issue to cause a denial of service.

It was discovered that the Kerberos kdcpreauth modules incorrectly tracked certain client requests. A remote attacker could possibly use this issue to bypass intended preauthentication requirements.

It was discovered that Kerberos incorrectly handled certain SPNEGO packets. A remote attacker could possibly use this issue to cause a denial of service.

It was discovered that Kerberos incorrectly handled certain IAKERB packets. A remote attacker could possibly use this issue to cause a denial of service.

It was discovered that Kerberos incorrectly handled certain TGS requests. A remote attacker could possibly use this issue to cause a denial of service.

The Cloud Foundry project released a BOSH stemcell version 3137 that has the patched version of the Linux kernel. A new Cloud Foundry rootfs was also released, cflinuxfs2 v.1.18.0, that has the patches.

Pivotal is releasing an updated version of Pivotal Cloud Foundry Suite which references this patched BOSH stemcell and CF rootfs.

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • All versions of Cloud Foundry BOSH stemcells prior to 3137 are vulnerable.
  • All versions of Cloud Foundry cflinuxfs2 prior to v.1.18.0.
  • Pivotal Cloud Foundry Elastic Runtime pre-1.6.5 versions.
  • Pivotal Ops Manager pre-1.5.10 versions and 1.6.x versions prior to 1.6.5.
  • Pivotal Redis pre-1.4.13 versions and 1.5.0.
  • Pivotal Gemfire SSC pre-1.1.4.0 versions.
  • Pivotal RabbitMQ pre-1.4.9 versions.
  • Pivotal Ops Metrics pre-1.4.7 versions and all 1.5.x versions.
  • Pivotal MySQL pre-1.6.3.3 versions and 1.7.0.x versions prior to 1.7.0.3.
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry project recommends that Cloud Foundry deployments run with BOSH stemcells 3137 or later versions and cflinuxfs2 v.1.18.0 or later versions.
  • Pivotal recommends that customers upgrade to the 1.6.5 or later versions of Pivotal Cloud Foundry Elastic Runtime.
  • 1.5.10 or later 1.5.x versions or the 1.6.3 or later versions of Pivotal Ops Manager.
  • The 1.1.4.0 or later versions of Pivotal Gemfire SSC.
  • 1.4.13 or later 1.4.x versions and 1.5.1 or later versions of Pivotal Redis.
  • 1.4.9 or later versions of RabbitMQ.
  • The 1.4.7 or later 1.4.x versions or the 1.6.0 or later versions of Pivotal Ops Metrics.
  • The 1.6.3.3 or later 1.6.x versions or the 1.7.0.3 or later versions of Pivotal MySQL.
Credit

N/A

References