USN-2806-1 Linux kernel vulnerability





Versions Affected
  • Ubuntu 14.04

Ben Serebrin discovered that the KVM hypervisor implementation in the Linux kernel did not properly catch Alignment Check exceptions. An attacker in a guest virtual machine could use this to cause a denial of service (system crash) in the host OS.

The Cloud Foundry project released a BOSH stemcell version 3130 that has the patched version of the Linux kernel.

Pivotal is releasing an updated version of Pivotal Cloud Foundry Suite which references this patched BOSH stemcell.

Affected Pivotal Products and Versions

Severity is high unless otherwise noted.

  • All versions of Cloud Foundry BOSH stemcells prior to 3130 have versions of the kernel vulnerable to USN-2806-1.
  • Pivotal Cloud Foundry Elastic Runtime pre-1.5.8 versions and versions 1.6.0, 1.6.1, and 1.6.2.
  • Pivotal Ops Manager pre-1.5.9 versions and versions 1.6.0 and 1.6.1.
  • Pivotal Redis pre-1.4.12 versions.
  • Pivotal Gemfire SSC pre- versions and versions and
  • Pivotal RabbitMQ pre-1.4.8 versions.
  • Pivotal Ops Metrics pre-1.4.6 versions and versions 1.5.0 and 1.5.1.
  • Pivotal MySQL pre- versions and versions and

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry project recommends that Cloud Foundry deployments run with BOSH stemcells 3130 or later versions.
  • Pivotal recommends that customers upgrade to the 1.5.8 or later 1.5.x versions or the 1.6.3 or later 1.6.x versions of Pivotal Cloud Foundry Elastic Runtime.
  • 1.5.9 or later 1.5.x versions or the 1.6.2 or later 1.6.x versions of Pivotal Ops Manager.
  • The or later versions of Pivotal Gemfire SSC, or version
  • 1.4.12 or later versions of Pivotal Redis.
  • 1.4.8 or later versions of RabbitMQ.
  • The 1.4.6 or later 1.4.x versions or the 1.5.2 or later 1.5.x versions of Pivotal Ops Metrics.
  • The or later 1.6.x versions or the or later 1.7.x versions of Pivotal MySQL.

Ben Serebrin