USN-2788-1 and USN-2788-2 unzip vulnerability


Severity

Medium

Vendor

unzip

Versions Affected
  • Ubuntu 14.04
Description

Gustavo Grieco discovered that unzip incorrectly handled certain password protected archives. If a user or automated system were tricked into processing a specially crafted zip archive, an attacker could possibly execute arbitrary code. (CVE-2015-7696)

Gustavo Grieco discovered that unzip incorrectly handled certain malformed archives. If a user or automated system were tricked into processing a specially crafted zip archive, an attacker could possibly cause unzip to hang, resulting in a denial of service. (CVE-2015-7697)

The Cloud Foundry project released a BOSH stemcell version 3130 that has the patched version of the Linux kernel. A new Cloud Foundry rootfs was also released, cflinuxfs2 v.1.17.0, that has the patches.

Pivotal is releasing an updated version of Pivotal Cloud Foundry Suite which references this patched BOSH stemcell.

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • All versions of Cloud Foundry BOSH stemcells prior to 3130 have versions of the kernel vulnerable to USN-2806-1.
  • All versions of Cloud Foundry cflinuxfs2 prior to v.1.17.0.
  • Pivotal Cloud Foundry Elastic Runtime pre-1.6.4 versions.
  • Pivotal Ops Manager pre-1.5.9 versions and versions 1.6.0 and 1.6.1.
  • Pivotal Redis pre-1.4.12 versions.
  • Pivotal Gemfire SSC pre-1.1.0.2 versions and versions 1.1.1.0 and 1.1.2.0.
  • Pivotal RabbitMQ pre-1.4.8 versions.
  • Pivotal Ops Metrics pre-1.4.6 versions and versions 1.5.0 and 1.5.1.
  • Pivotal MySQL pre-1.6.3.2 versions and versions 1.7.0.0 and 1.7.0.1.
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry project recommends that Cloud Foundry deployments run with BOSH stemcells 3130 or later versions and cflinuxfs2 v.1.17.0 or later versions.
  • Pivotal recommends that customers upgrade to the 1.6.4 or later versions of Pivotal Cloud Foundry Elastic Runtime.
  • 1.5.9 or later 1.5.x versions or the 1.6.2 or later 1.6.x versions of Pivotal Ops Manager.
  • The 1.1.3.0 or later versions of Pivotal Gemfire SSC, or version 1.1.0.2.
  • 1.4.12 or later versions of Pivotal Redis.
  • 1.4.8 or later versions of RabbitMQ.
  • The 1.4.6 or later 1.4.x versions or the 1.5.2 or later 1.5.x versions of Pivotal Ops Metrics.
  • The 1.6.3.2 or later 1.6.x versions or the 1.7.0.2 or later 1.7.x versions of Pivotal MySQL.
Credit

Gustavo Grieco

References