USN-2778-1 Linux kernel vulnerabilities


Severity

Medium

Vendor

Vivid

Versions Affected
  • Ubuntu 14.04
Description

It was discovered that the Linux kernel did not check if a new IPv6 MTU set by a user space application was valid. A remote attacker could forge a route advertisement with an invalid MTU that a user space daemon like NetworkManager would honor and apply to the kernel, causing a denial of service. (CVE-2015-0272)

It was discovered that virtio networking in the Linux kernel did not handle fragments correctly, leading to kernel memory corruption. A remote attacker could use this to cause a denial of service (system crash) or possibly execute code with administrative privileges. (CVE-2015-5156)

It was discovered that the Reliable Datagram Sockets (RDS) implementation in the Linux kernel did not verify sockets were properly bound before attempting to send a message, which could cause a NULL pointer dereference. An attacker could use this to cause a denial of service (system crash). (CVE-2015-6937)

Ben Hutchings discovered that the Advanced Union Filesystem (aufs) for the Linux kernel did not correctly handle references of memory mapped files from an aufs mount. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code with administrative privileges. (CVE-2015-7312)

The Cloud Foundry project released a BOSH stemcell version 3112 that has the patched version of the Linux kernel.

Pivotal is releasing an updated version of Pivotal Cloud Foundry Suite which references this patched BOSH stemcell.

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • All versions of Cloud Foundry BOSH stemcells prior to 3112 have versions of the kernel vulnerable to USN-2778-1
  • Pivotal Cloud Foundry Elastic Runtime pre-1.5.7 versions and version 1.6.0
  • Pivotal Ops Manager pre-1.5.8 versions and version 1.6.0
  • Pivotal Redis pre-1.4.11 versions
  • Pivotal Gemfire SSC pre-1.1.0.1 versions and version 1.1.1.0
  • Pivotal RabbitMQ pre-1.4.7 versions
  • Pivotal Ops Metrics pre-1.4.5 versions and version 1.5.0
  • Pivotal MySQL pre-1.6.4 versions and version 1.7.0.
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry project recommends that Cloud Foundry deployments run with BOSH stemcells 3112 or later versions.
  • Pivotal recommends that customers upgrade to the 1.5.7 or later 1.5.x versions or the 1.6.1 or later 1.6.x versions of Pivotal Cloud Foundry Elastic Runtime
  • 1.5.8 or later 1.5.x versions or the 1.6.1 or later 1.6.x versions of Pivotal Ops Manager
  • The 1.1.2.0 or later versions of Pivotal Gemfire SSC, or version 1.1.0.1
  • 1.4.11 or later versions of Pivotal Redis
  • 1.4.7 or later versions of RabbitMQ
  • The 1.4.5 or later 1.4.x versions or the 1.5.1 or later 1.5.x versions of Pivotal Ops Metrics
  • The 1.6.4 or later 1.6.x versions or the 1.7.1 or later 1.7.x versions of Pivotal MySQL.
Credit

Ben Hutchings

References