Pivotal + VMware: Transforming how more of the world builds software

All Vulnerability Reports

CVE-2019-11281: RabbitMQ XSS attack


Severity

Low

Vendor

Pivotal

Description

Pivotal RabbitMQ, versions prior to v3.7.18, and RabbitMQ for PCF, versions 1.15.x prior to 1.15.13, versions 1.16.x prior to 1.16.6, and versions 1.17.x prior to 1.17.3, contain two components, the virtual host limits page, and the federation management UI, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack that would gain access to virtual hosts and policy management information.

Affected Pivotal Products and Versions

Severity is low unless otherwise noted.

  • RabbitMQ
    • All versions prior to v3.7.18
  • RabbitMQ for PCF
    • 1.15 versions prior to 1.15.13
    • 1.16 versions prior to 1.16.6
    • 1.17 versions prior to 1.17.3
Mitigation

Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include:

  • RabbitMQ
    • v3.7.18
  • RabbitMQ for PCF
    • 1.15.13
    • 1.16.6
    • 1.17.3
Credit

This issue was responsibly reported by Markus Alvila (@RareData).

References
History

2019-10-14: Initial vulnerability report published.

Contact us