All Vulnerability Reports

CVE-2019-11277: Volume Services is vulnerable to an LDAP injection attack


Severity

High

Vendor

Pivotal Cloud Foundry

Description

Cloud Foundry NFS Volume Service, 1.7.x versions prior to 1.7.11 and 2.x versions prior to 2.3.0, is vulnerable to LDAP injection. A remote authenticated malicious space developer can potentially inject LDAP filters via service instance creation, facilitating the malicious space developer to deny service or perform a dictionary attack.

Affected Pivotal Products and Versions

Severity is high unless otherwise noted.

  • Pivotal Isolation Segment
    • 2.5 versions prior to 2.5.9
    • 2.4 versions prior to 2.4.13
  • Pivotal Application Service (PAS)
    • 2.5 versions prior to 2.5.10
    • 2.4 versions prior to 2.4.14
Mitigation

Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include:

  • Pivotal Isolation Segment
    • 2.5.9
    • 2.4.13
  • Pivotal Application Service (PAS)
    • 2.5.10
    • 2.4.14
References
History

2019-09-23: Initial vulnerability report published

Contact us