All Vulnerability Reports

CVE-2018-15797: NFS Volume release errand leaks cf admin credentials in logs


Severity

High

Vendor

Pivotal Cloud Foundry

Description

Cloud Foundry NFS volume release, 1.2.x prior to 1.2.5, 1.5.x prior to 1.5.4, 1.7.x prior to 1.7.3, logs the cf admin username and password when running the nfsbrokerpush BOSH deploy errand. A remote authenticated user with access to BOSH can obtain the admin credentials for the Cloud Foundry Platform through the logs of the NFS volume deploy errand.

Affected Pivotal Products and Versions

Severity is high unless otherwise noted.

  • Pivotal Application Service
    • 2.3.x versions prior to 2.3.4
    • 2.2.x versions prior to 2.2.10
    • 2.1.x versions prior to 2.1.18
  • Pivotal Cloud Foundry Isolation Segment
    • 2.3.x versions prior to 2.3.4
    • 2.2.x versions prior to 2.2.9
    • 2.1.x versions prior to 2.1.15
Mitigation

Users of affected versions should apply the following mitigation:

  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.3.4, 2.2.10, 2.1.18
    • Pivotal Cloud Foundry Isolation Segment: 2.3.4, 2.2.9, 2.1.15
References
History

2018-12-03: Initial vulnerability report published