All Vulnerability Reports

CVE-2018-15755: CF networking internal policy server SQL injection


Severity

Medium

Vendor

Pivotal

Description

Cloud Foundry CF Networking, versions 2.11.0 through 2.15.0, contain an internal api endpoint vulnerable to SQL injection between Diego cells and the policy server. A remote authenticated malicious user with mTLS certs can issue arbitrary SQL queries and gain access to the policy server.

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Pivotal Application Service
    • 2.3.x versions prior to 2.3.1
  • PCF Isolation Segment
    • 2.3.x versions prior to 2.3.1
Mitigation

Users of affected versions should apply the following mitigation:

  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.3.1
    • PCF Isolation Segment: 2.3.1
References
History

2018-10-02: Initial vulnerability report published