CVE-2015-0201 Insufficiently random session id in Java SockJS client




Spring by Pivotal

Versions Affected
  • Spring Framework 4.1.0 to 4.1.4

Session id generation in the Java SockJS client is not sufficiently secure and could allow a user to send messages to another user’s session.

Note that this only affects users of the Java SockJS client, which generates its own session id. It does not affect browser clients even if they’re connecting to the same server.

Furthermore, since SockJS is a transport layer, when using a higher level messaging protocol on top such as STOMP over WebSocket with the spring-messaging module, application-level security may already be getting applied to STOMP messages and that can neutralize the impact of any potential attacks.


Users of affected versions should apply the following mitigation:

  • Users of 4.1.x should upgrade to 4.1.5 or later

Philippe Arteau found and responsibly reported the problem to Pivotal.


2015-Mar-06: Initial vulnerability report published.