Pivotal + VMware: Transforming how more of the world builds software

All Vulnerability Reports

USN-3962-1: libpng vulnerability


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 18.04
Description

It was discovered that libpng incorrectly handled certain memory operations. If a user or automated system were tricked into opening a specially crafted PNG file, a remote attacker could use this issue to cause libpng to crash, resulting in a denial of service, or possibly execute arbitrary code.

CVEs contained in this USN include: CVE-2019-7317

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Pivotal Application Service includes vulnerable container rootfs in the following releases:
    • 2.5.x versions prior to 2.5.3
    • 2.4.x versions prior to 2.4.7
    • 2.3.x versions prior to 2.3.11
  • PCF Isolation Segment includes vulnerable container rootfs in the following releases:
    • 2.5.x versions prior to 2.5.3
    • 2.4.x versions prior to 2.4.7
    • 2.3.x versions prior to 2.3.11
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry security team recommends upgrading BOSH to the affected OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.5.3, 2.4.7, 2.3.11
    • PCF Isolation Segment: 2.5.3, 2.4.7, 2.3.11
References
문의