Pivotal + VMware: Transforming how more of the world builds software

All Vulnerability Reports

CVE-2019-3799: Directory Traversal with spring-cloud-config-server


Severity

High

Vendor

Spring by Pivotal

Description

Spring Cloud Config, versions 2.1.x prior to 2.1.2, versions 2.0.x prior to 2.0.4, and versions 1.4.x prior to 1.4.6, and older unsupported versions allow applications to serve arbitrary configuration files through the spring-cloud-config-server module. A malicious user, or attacker, can send a request using a specially crafted URL that can lead a directory traversal attack.

Affected Pivotal Products and Versions

Severity is high unless otherwise noted.

  • Spring Cloud Config 2.1.0 to 2.1.1
  • Spring Cloud Config 2.0.0 to 2.0.3
  • Spring Cloud Config 1.4.0 to 1.4.5
  • Older unsupported versions are also affected
Mitigation

Users of affected versions should apply the following mitigation:

  • 2.1.x users should upgrade to 2.1.2
  • 2.0.x users should upgrade to 2.0.4
  • 1.4.x users should upgrade to 1.4.6
  • Older versions should upgrade to a supported branch
  • Note that spring-cloud-config-server should only be available on internal networks to clients that require it and it should be secured with Spring Security, this limits exposure to this vulnerability to those with internal network access and those users with proper authentication.
Credit

This issue was identified and responsibly reported by Vern (vernhk@qq.com from PingAn Galaxy Lab).

References
History

2019-04-16: Initial vulnerability report published.

お問い合わせ