Pivotal + VMware: Transforming how more of the world builds software

All Vulnerability Reports

CVE-2019-3790: Ops Manager uaa client issues tokens after refresh token expiration


Severity

Medium

Vendor

Pivotal Cloud Foundry

Description

The Pivotal Ops Manager, 2.2.x versions prior to 2.2.23, 2.3.x versions prior to 2.3.16, 2.4.x versions prior to 2.4.11, and 2.5.x versions prior to 2.5.3, contain configuration that circumvents refresh token expiration. A remote authenticated user can gain access to a browser session that was supposed to have expired, and access Ops Manager resources.

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Pivotal Ops Manager 2.2.x versions prior to 2.2.23
  • Pivotal Ops Manager 2.3.x versions prior to 2.3.16
  • Pivotal Ops Manager 2.4.x versions prior to 2.4.11
  • Pivotal Ops Manager 2.5.x versions prior to 2.5.3
Mitigation

Users of affected versions should apply the following mitigation:

  • Releases that have fixed this issue include:
    • Pivotal Ops Manager 2.2.23
    • Pivotal Ops Manager 2.3.16
    • Pivotal Ops Manager 2.4.11
    • Pivotal Ops Manager 2.5.3
References
History

2019-05-24: Initial vulnerability report published

お問い合わせ