All Vulnerability Reports

USN-3910-2: Linux kernel (Xenial HWE) vulnerabilities


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 14.04
Description

USN-3910-1 fixed vulnerabilities in the Linux kernel for Ubuntu 16.04 LTS. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 16.04 LTS for Ubuntu 14.04 LTS.

It was discovered that the f2fs filesystem implementation in the Linux kernel did not handle the noflush_merge mount option correctly. An attacker could use this to cause a denial of service (system crash). (CVE-2017-18241)

It was discovered that the procfs filesystem did not properly handle processes mapping some memory elements onto files. A local attacker could use this to block utilities that examine the procfs filesystem to report operating system state, such as ps(1). (CVE-2018-1120)

Hui Peng and Mathias Payer discovered that the Option USB High Speed driver in the Linux kernel did not properly validate metadata received from the device. A physically proximate attacker could use this to cause a denial of service (system crash). (CVE-2018-19985)

It was discovered that multiple integer overflows existed in the hugetlbfs implementation in the Linux kernel. A local attacker could use this to cause a denial of service (system crash). (CVE-2018-7740)

Jann Horn discovered a race condition in the fork() system call in the Linux kernel. A local attacker could use this to gain access to services that cache authorizations. (CVE-2019-6133)

CVEs contained in this USN include: CVE-2018-1120, CVE-2019-6133, CVE-2017-18241, CVE-2018-19985, CVE-2018-7740

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.
  • Pivotal Application Service includes vulnerable stemcells in the following releases:
    • 2.2.x versions prior to 2.2.14
  • PCF Isolation Segment includes vulnerable stemcells in the following releases:
    • 2.2.x versions prior to 2.2.14
  • Pivotal Operations Manager is vulnerable in the following releases:
    • 2.2.x versions prior to 2.2.21
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry security team recommends upgrading BOSH to the affected OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.2.14
    • PCF Isolation Segment: 2.2.14
    • Pivotal Operations Manager: 2.2.21
References
Contactez-nous