Pivotal + VMware: Transforming how more of the world builds software

All Vulnerability Reports

USN-3820-2: Linux kernel (HWE) vulnerabilities


Severity

High

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 16.04
Description

USN-3820-1 fixed vulnerabilities in the Linux kernel for Ubuntu 18.04 LTS. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 18.04 LTS for Ubuntu 16.04 LTS.

Felix Wilhelm discovered that the Xen netback driver in the Linux kernel did not properly perform input validation in some situations. An attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2018-15471)

It was discovered that the generic SCSI driver in the Linux kernel did not properly enforce permissions on kernel memory access. A local attacker could use this to expose sensitive information or possibly elevate privileges. (CVE-2017-13168)

It was discovered that an integer overflow existed in the CD-ROM driver of the Linux kernel. A local attacker could use this to expose sensitive information (kernel memory). (CVE-2018-16658)

It was discovered that an integer overflow existed in the HID Bluetooth implementation in the Linux kernel that could lead to a buffer overwrite. An attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2018-9363)

CVEs contained in this USN include: CVE-2017-13168, CVE-2018-16658, CVE-2018-9363, CVE-2018-15471

Affected Pivotal Products and Versions

Severity is high unless otherwise noted.

  • Vulnerable Cloud Foundry components individually listed here.
  • Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.
  • Pivotal Application Service includes vulnerable stemcells in the following releases:
    • 2.3.x versions prior to 2.3.4
  • PCF Isolation Segment includes vulnerable stemcells in the following releases:
    • 2.3.x versions prior to 2.3.4
  • Pivotal Operations Manager is vulnerable in the following releases:
    • 2.3.x versions prior to 2.3.6
Mitigation

Users of affected versions should apply the following mitigation:

  • The Cloud Foundry security team recommends upgrading BOSH to the affected OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:
    • Pivotal Application Service: 2.3.4
    • PCF Isolation Segment: 2.3.4
    • Pivotal Operations Manager: 2.3.6
References
Kontakt