All Vulnerability Reports

CVE-2018-15798: Pivotal Concourse allows malicious redirect urls on login


Severity

High

Vendor

Pivotal

Description

Pivotal Concourse Release, versions 4.x prior to 4.2.2, login flow allows redirects to untrusted websites. A remote unauthenticated attacker could convince a user to click on a link using the oAuth redirect link with an untrusted website and gain access to that user's access token in Concourse.

Affected Pivotal Products and Versions

Severity is high unless otherwise noted.

  • Concourse all versions 4.x prior to 4.2.2
Mitigation

Users of affected versions should apply the following mitigation:

  • Releases that have fixed this issue include:
    • Concourse: 4.2.2
Credit

This vulnerability was responsibly reported by Atanas Pashov of SAP.

References
History

2018-12-13: Initial vulnerability report published

2018-12-17: Added credit

Kontakt