Pivotal + VMware: Transforming how more of the world builds software

All Vulnerability Reports

CVE-2019-3797: Additional information exposure with Spring Data JPA derived queries


Severity

Low

Vendor

Spring by Pivotal

Description

This affects Spring Data JPA in versions up to and including 2.1.5, 2.0.13 and 1.11.19. Derived queries using any of the predicates ‘startingWith’, ‘endingWith’ or ‘containing’ could return more results than anticipated when a maliciously crafted query parameter value is supplied. Also, LIKE expressions in manually defined queries could return unexpected results if the parameter values bound did not have escaped reserved characters properly.

Affected Pivotal Products and Versions

Severity is low unless otherwise noted.

  • Spring Data JPA 2.0 to 2.0.13
  • Spring Data JPA 2.1 to 2.1.5
  • Spring Data JPA 1.11 to 1.11.19
  • Older unsupported versions are also affected
Mitigation

Users of affected versions should apply the following mitigation:

  • 2.1.x users should upgrade to 2.1.6 (included in Spring Boot 2.1.4)
  • 2.0.x users should upgrade to 2.0.14 (included in Spring Boot 2.0.9)
  • 1.11.x users should upgrade to 1.11.20 (included in Spring Boot 1.5.20)
  • Older versions should upgrade to a supported branch
  • There are no other mitigation steps necessary. Note, that with the current releases, the 2.0 branch of both Spring Data and Spring Boot is EOL and we highly recommend to upgrade
Credit

This issue was identified and responsibly reported by Maruthi Adithya G

联系我们