All Vulnerability Reports

CVE-2019-18801, CVE-2019-18838, CVE-2019-18802: MySQL for Pivotal Platform consumes a vulnerable version of Envoy


Severity

Critical

Vendor

Pivotal

Description

MySQL for Pivotal Platform, 2.7.x versions prior to 2.7.4, consumes a version of Envoy prior to 1.12.2, leaving it vulnerable to the following:

CVE-2019-18801: An untrusted remote client may send HTTP/2 requests that write to the heap outside of the request buffers when the upstream is HTTP/1. This may be used to corrupt nearby heap contents (leading to a query-of-death scenario) or may be used to bypass Envoy's access control mechanisms such as path based routing. An attacker can also modify requests from other users that happen to be proximal temporally and spatially.

CVE-2019-18802: Upon receipt of a malformed HTTP request without a Host header, it sends an internally generated "Invalid request" response. This internally generated response is dispatched through the configured encoder filter chain before being sent to the client. An encoder filter that invokes route manager APIs that access a request's Host header causes a NULL pointer dereference, resulting in abnormal termination of the Envoy process.

CVE-2019-18838: An untrusted remote client may send an HTTP header (such as Host) with whitespace after the header content. Envoy will treat "header-value " as a different string from "header-value" so for example with the Host header "example.com " one could bypass "example.com" matchers.

Affected Pivotal Products and Versions

Severity is critical unless otherwise noted.

  • MySQL for Pivotal Plaform
    • 2.7 versions prior to 2.7.4
Mitigation

Users of affected versions should apply the following mitigation or upgrade:

  • MySQL for Pivotal Plaform
    • 2.7.4
References
History

2020-01-10: Initial vulnerability report published.

联系我们