All Vulnerability Reports

CVE-2019-11270: UAA clients.write vulnerability


Severity

High

Vendor

Pivotal Cloud Foundry

Description

Pivotal Application Service (2.3.x versions prior to 2.3.15, 2.4.x versions prior to 2.4.11, 2.5.x versions prior to 2.5.7, and 2.6.x versions prior to 2.6.2), Pivotal Container Service (1.3.x versions prior to 1.3.8, and 1.4.x versions prior to 1.4.2) and Pivotal Ops Manager (2.3.x versions prior to 2.3.22, 2.4.x versions prior to 2.4.16, 2.5.x versions prior to 2.5.10, and 2.6.x versions prior to 2.6.4) contain a dependency on a vulnerable version of Cloud Foundry UAA where a malicious client possessing the ‘clients.write’ authority or scope can bypass the restrictions imposed and create clients with arbitrary scopes that the creator does not possess.

Affected Pivotal Products and Versions

Severity is high unless otherwise noted.

  • Pivotal Application Service (PAS)
    • 2.3.x versions prior to 2.3.15
    • 2.4.x versions prior to 2.4.11
    • 2.5.x versions prior to 2.5.7
    • 2.6.x versions prior to 2.6.2
  • Pivotal Container Service (PKS)
    • 1.3.x versions prior to 1.3.8
    • 1.4.x versions prior to 1.4.2
  • Pivotal Ops Manager
    • 2.3.x versions prior to 2.3.22
    • 2.4.x versions prior to 2.4.16
    • 2.5.x versions prior to 2.5.10
    • 2.6.x versions prior to 2.6.4
Mitigation

Users of affected versions should apply the following mitigation:

  • Pivotal Application Service (PAS)
    • 2.3.15
    • 2.4.11
    • 2.5.7
    • 2.6.2
  • Pivotal Container Service (PKS)
    • 1.3.8
    • 1.4.2
  • Pivotal Ops Manager
    • 2.3.22
    • 2.4.16
    • 2.5.10
    • 2.6.4
References
History

2019-08-01: Initial vulnerability report published.

2019-08-09: Updated description for clarity.

2019-08-20: Updated impacted products and description.

联系我们