All Vulnerability Reports

CVE-2019-11247: Kubernetes API Server Vulnerability


Severity

Medium

Vendor

Pivotal

Description

Pivotal Container Service (1.4.x versions prior to 1.4.3) through its dependency on a vulnerable version of Kubernetes kube-apiserver (affected versions include versions prior to 1.13.9, versions prior to 1.14.5, versions prior to 1.15.2, and versions 1.7, 1.8, 1.9, 1.10, 1.11, 1.12), mistakenly allows access to a cluster-scoped custom resource if the request is made as if the resource were namespaced. Authorizations for the resource accessed in this manner are enforced using roles and role bindings within the namespace, meaning that a user with access only to a resource in one namespace could create, view update or delete the cluster-scoped resource (according to their namespace role privileges).

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Pivotal Container Service (PKS)
    • 1.4 versions prior to 1.4.3
Mitigation

Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include:

  • Pivotal Container Service (PKS)
    • 1.4.3
References
History

2019-10-15: Initial vulnerability report published.

联系我们