CVE-2013-6429 Fix for XML External Entity (XXE) Injection (CVE-2013-7315) in Spring Framework was Incomplete




Spring by Pivotal

Versions Affected
  • Spring MVC 3.0.0 to 3.2.4
  • Spring MVC 4.0.0.M1-4.0.0.RC1
  • Earlier unsupported versions may be affected

Spring MVC's SourceHttpMessageConverter also processed user provided XML and neither disabled XML external entities nor provided an option to disable them. SourceHttpMessageConverter has been modified to provide an option to control the processing of XML external entities and that processing is now disabled by default. It was subsequently discovered that this fix was also incomplete (CVE-2014-0054).


Users of affected versions should apply the following mitigation:

  • Users of 3.x should upgrade to 3.2.5 or later
  • Users of 4.x should upgrade to 4.0.0 or later (This is also fixed in 4.0.0-RC2 but users are recommended to use 4.0.0 or later)
  • To fully mitigate this issue (including CVE-2014-0054), users of 3.x should upgrade to 3.2.8 or later and users of 4.x should upgrade to 4.0.2 or later.

This issue was identified by the Spring development team.


2014-Jan-15: Initial vulnerability report.

2014-Jun-19: Update to reflect split of CVE-2013-4152 into CVE-2013-4152 and CVE-2013-7315. Added information on additional vulnerability report that identified that this fix was incomplete.

Glad You're Ready. Let's Get Started!

Let us know how we can contact you.

Thank you!

We'll respond shortly.